/ jQuery

jQuery 2.0 正式版出炉,不再支持 IE 6-8

jQuery 2.0 正式版如时发布,不再支持 IE 6/7/8 浏览器。因此该版本更小、更快。jQuery 团队将继续对 1.x 版本分支进行维护,如果你无法抛弃 IE 6/7/8 的话(谁不想啊,市场不让),可继续使用 jQuery 1.9 和即将发布的 1.10。

从 1.9 版本之前升级而且还没来得及更新代码的用户,推荐使用 jQuery Migrate plugin ,具体查阅 jQuery 1.9 Upgrade Guide。需要注意的是,生产环境中从引用 jQuery 官方或者 Google 、Microsoft CDN 引用文件时,应该指明具体的版本号,不具体的版本号比如 /2/jquery-latest.js is 会影响网站性能

对于 IE6-8 ,可以使用条件注释引入不同的版本。

<!--[if lt IE 9]>
    <script src="http://code.jquery.com/jquery-1.9.1.min.js"></script>
<![endif]-->
<!--[if gte IE 9]><!-->
    <script src="http://code.jquery.com/jquery-2.0.0.min.js"></script>
<!--<![endif]-->